Issue Creating New Accounts
Incident Report for edX's Support Communication
Resolved
The error has been resolved and learners can now create new accounts.
Posted Jun 03, 2022 - 14:32 UTC
Investigating
There is currently a problem some learners are experiencing when attempting to create a new account. We are currently investigating.
Posted Jun 03, 2022 - 14:08 UTC
This incident affected: Learner-Facing Issues.