Payment Issues
Incident Report for edX's Support Communication
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 14:21 UTC
Monitoring
We're monitoring intermittent payment issues.
Posted Jan 13, 2022 - 21:29 UTC
Investigating
We're actively investigating intermittent issues with our payment system.
Posted Jan 13, 2022 - 18:46 UTC
This incident affected: Learner-Facing Issues.